Jesoba.com is launched, Click below image to access it

Jesoba.com is launched, Click below image to access it
Technology and Entertainment Blog

The databases require upgrade because their versions are older than backwards compatible range

Problem Title: The databases require upgrade because their versions are older than backwards compatible range
  
Case ID: CS002

Problem Description:
===============
When we try to update SharePoint databases, the databases are not getting updated and we still see following entries in Central Administration Health section with databases names which has issues.
Title: Databases running in compatibility range, upgrade recommended
Severity: 1 – Error

And Or
Title: Databases require upgrade or not supported
Severity: 1 – Error

Server Configuration:
================
OS            - Window Server 2008
SharePoint    - SharePoint 2010
SQL Server    - Haven't checked should be SQL 2008.
IIS           - 7

Observation
:
===========
- From event viewer found error event 2137 and error event 2138 related to the same issue.

Steps Taken:
==========
- Ran SharePoint configuration wizard but it didn’t help.
- Restarted SQL Service and ran following command.
This also didn’t help.
psconfig -cmd upgrade -inplace b2b –force
- Installed latest hotfix and ran following command which solved the issue.
PSConfig.exe -cmd upgrade -inplace b2b -force -cmd applicationcontent -install -cmd installfeatures

Solution:
=======
- Download & Install latest hotfix and run following updates.
PSConfig.exe -cmd upgrade -inplace b2b -force -cmd applicationcontent -install -cmd installfeatures
- The issue is fixed now.

Keyword: error 2137, error 2138, error event, sharepoint

Reference: N\A

Google+ Badge

About Author

My photo

I am Senior Server Expert and Professional Blogger.